【WordPress】5.5にアップデートでClassic Editorも使えない。元に戻す解決方法はこれ!




たくさんのサイトからのご訪問ありがとうございます!

はじめまして
当サイト(ばいばいアマリリス)管理人で漫画好きの一ノ瀬ポーです。(@byebyeamaryllis

2020年8月wordpressの最新版5.5がリリースされました。その名はEckstine(エクスタイン)。古いジャズシンガーのBilly Eckstine(ビリー・エクスタイン)から名付けられています。

なかなか通なことしてくれるじゃないのとジャズファンの私は、ウキウキとバカ顔しながら早速アップデートしました。

そうしたらclassic editorが使えなくなってしまいました!お〜い、そりゃないぜ。

classic editorとは
2018年12月にwordpressのアップデート5.0から正式採用された新エディタ「Gutenberg」を旧エディタで記事編集できるプラグインです。

簡単に言うと、「新しいのがよくわかんないなら、元に戻してあげるよ」機能です。

wordpress5.5にアップデートで困った!

私のプログテーマはSTORKを使用しています。STORK19 という最新バーションがリリースされていますが、私のは旧ストークになります。

主な不具合はclassic editor投稿画面で

ビジュアル画面からテキスト画面に切り替わらない。

・プラグインのAddQuictagが表示されない

えーと、この二つが使えないって記事制作にとって致命的なんですけど・・・。今まではアップデートしてもまだclassic editor使えるもんね〜と気軽に考えていました。あぁ、やばい。

とりあえずclassic editor停止して、新しい投稿画面5.5で記事を制作しようとしたのですが、なんだかよくわからない。

もしかしたらうまく使えばAddQuictagなんてなくてもサクサク書けちゃうかな〜なんて甘い期待は崩れ去りました。

本当はちゃんと新しいブロック機能の記事制作を勉強すればいいだけの話なんですけど、やっぱり慣れている編集画面がいいですよね。

wordpress5.5にアップデートで試行錯誤!

そこでやっぱりclassic editorに戻して今度は

キャッシュクリア

・使っているテーマアップデート

プラグインの更新、さらにプラグインを1つ1つ停止してプラグインの干渉によって不具合を起こしてないか試してみました

これで治ったという人もチラホラいますので、まずはこれらを試すのがいいとおもいます。

心配な人は実行する前にバックアップしてね。面倒臭くてしない私の真似はしないように。

で、すべて試したけどやっぱりだめでした。

wordpress5.5にアップデートを元に戻すプラグイン導入!

こうなったら最後の手段。基本的にはセキュリティなど最新版が一番なのであまりやりたくなかったし、おすすめはしませんがwordpressをダウングレードしちゃいましょう。

そんなことできるの?できます。プラグインでね。

使うプラグインは「wp downgrade specific core version」です!

管理画面からプラグイン→新規追加から「wp downgrade specific core version」と検索入力して下さいね。見つかればいつもの通り、「今すぐインストール」からの「有効化」にしましょう。

私の場合は検索画面不具合が起きていて検索できない状態だったので、ここからファイルをダウンロードして、管理画面のプラグインのアップロードからインストールしました。

「wp downgrade specific core version」の設定は簡単

wordpress 5.5 ダウングレード

「wp downgrade specific core version」の設定はいたって簡単です。

WordPress Target Version:に5.4と入力して変更を保存。

さらにupdowngradecoreをクリックすると自動的にwordpress更新画面に切り替わりますので、再インストールをクリックしましょう。

これで無事に5.5から5.4にダウングレードできたとおもいます。

さてさて、classic editorの投稿画面を見ると、テキスト画面切り替わるAddQuictagも使える

ということでなんとか治りました。しかしそれがダウングレードでということはやっぱりひっかかるものがありますね。

5.5はSEO・速度・セキュリティがかなり向上しているようです。

classic editorはwordpress公式のプラグインで2022年までは使えると謳っている以上、テキスト画面に切り替えられないなんて致命的な不具合はちょっとね。

しかし裏を返せば2022年までにはこの新しい投稿画面を攻略しないとってことですが。(延長する可能性はあり)

5・5で困っている方はかなりいるとおもうので、また修正版が出るとおもいますが、あまりプログラムに詳しくない人などはtwitter等で情報を得てから導入するのもがいいとおもいます。

またグレードダウンしたことで、今度はプラグインの最新版が不具合を起こすこともありそうです。私の場合「TynyMCE Advanced」から警告が来ました。

その場合はTynyMCE Advancedの古いバージョンをダウンロードしてインストールし直せばOKです。設定はやり直しです。

ではまだまだ混乱中ですが、困っている方は最後の砦としてダウングレードもありだとおもいます。

またダウングレードに伴い不具合が出ても当サイトでは補償できませんので自己責任でお願いしますね。

最後まで読んで頂きありがとうございました

「当サイト人気記事」

・【車検】予約なら「楽天車検」がおすすめ!実際に経験した口コミ ポイント大量ゲットで節約しよう

・【無料漫画アプリ人気7選】病院の待ち時間が長い!空き時間や暇つぶしに最適で今すぐ読めちゃう

2019年【おすすめ】の連載中漫画はコレだ!今すぐあなたに読んで欲しい作品を集めました【試し読み】【無料】

・【新世紀エヴァンゲリオン】の【ジェリコの壁】ってなんだろう? ドラマ【あなたには帰る家がある】にも登場

・【ループ】何度も繰り返す物語 ループものに名作あり!映画・アニメ・漫画・歌舞伎をご紹介 タイムトラベルもあり

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

ABOUTこの記事をかいた人

元古本屋店員。40代中年。映画・漫画・アニメ・歌舞伎・落語・小説・音楽全般などが好きです。国内・国際政治や出来事を勉強しつつ、それに関連するものを紹介できたらと思っています。宅建資格挑戦中。最近父になりました。